Skip to content

chore(all): update deps (major) - #726

Open
renovate-bot wants to merge 1 commit into
openconfig:mainfrom
renovate-bot:renovate/major-deps
Open

renovate-bot wants to merge 1 commit into
openconfig:mainfrom
renovate-bot:renovate/major-deps

Conversation

@renovate-bot

@renovate-bot renovate-bot commented Sep 15, 2026 •

Copy link
Copy Markdown
Contributor

ℹ️ Note

This PR body was truncated due to platform limits.

This PR contains the following updates:

Package Type Update Change Age Confidence
bazel major 8.4.1 → 9.2.0 age confidence
com_google_absl http_archive major 20250512.2 → 20250814.2 age confidence
github.com/osrg/gobgp/v3 require major v3.37.0 → v4.9.0 age confidence
k8s.io/klog require major v1.0.0 → v2.140.0 age confidence
rules_python bazel_dep major 1.3.0 → 2.3.4 age confidence
rules_python http_archive major 1.3.0 → 2.3.4 age confidence

Release Notes

bazelbuild/bazel (bazel)

v9.2.0

Compare Source


Release Notes:

v9.1.1

Compare Source


Release Notes:

v9.1.0

Compare Source


Release Notes:

v9.0.2

Compare Source


Release Notes:

v9.0.1

Compare Source


Release Notes:

v9.0.0

Compare Source


Release Notes:

v8.8.1

Compare Source


Release Notes:

v8.8.0

Compare Source


Release Notes:

v8.7.0

Compare Source


Release Notes:

v8.6.0

Compare Source


Release Notes:

v8.5.1

Compare Source


Release Notes:

v8.5.0

Compare Source


Release Notes:

v8.4.2

Compare Source


Release Notes:

abseil/abseil-cpp (com_google_absl)

v20250814.2: Abseil LTS branch, August 2025, Patch 2

Compare Source

Abseil LTS 2025081.2

What's New:

  • absl::Mutex now contains lower-case method names like lock() and shared_lock() to align with standard C++ mutex methods. This allows absl::Mutex to be used with std::scoped_lock and friends. The old names are still present but may be removed in a future release.
  • The RAII Mutex-locker types like absl::MutexLock, absl::ReaderMutexLock, and friends now accept references to absl::Mutex. The pointer-accepting constructors are now deprecated, and may be removed in a future release.

Breaking Changes:

  • Nullability template types, which were deprecated in the May 2025 release, have been removed.
  • absl::string_view(nullptr), which is undefined behavior according to the C++ standard, now triggers an assert failure. Note that unless you changed absl/base/options.h, absl::string_view is an alias for std::string_view, so by default you will be inheriting the behavior of your standard library instead of using the Abseil implementation.
  • Abseil's hash tables now require a hash function that has a return type with size >= sizeof(size_t).

Baseline: 987c57f
Cherry-pick: d38452e (Patch 1)
Cherry-pick: 7313246 (Patch 2)

v20250814.1: Abseil LTS branch, August 2025, Patch 1

Compare Source

Abseil LTS 2025081.1

What's New:

  • absl::Mutex now contains lower-case method names like lock() and shared_lock() to align with standard C++ mutex methods. This allows absl::Mutex to be used with std::scoped_lock and friends. The old names are still present but may be removed in a future release.
  • The RAII Mutex-locker types like absl::MutexLock, absl::ReaderMutexLock, and friends now accept references to absl::Mutex. The pointer-accepting constructors are now deprecated, and may be removed in a future release.

Breaking Changes:

  • Nullability template types, which were deprecated in the May 2025 release, have been removed.
  • absl::string_view(nullptr), which is undefined behavior according to the C++ standard, now triggers an assert failure. Note that unless you changed absl/base/options.h, absl::string_view is an alias for std::string_view, so by default you will be inheriting the behavior of your standard library instead of using the Abseil implementation.
  • Abseil's hash tables now require a hash function that has a return type with size >= sizeof(size_t).

Baseline: 987c57f
Cherry-pick: d38452e (Patch 1)

v20250814.0: Abseil LTS branch, August 2025

Compare Source

Abseil LTS 2025081.0

What's New:

  • absl::Mutex now contains lower-case method names like lock() and shared_lock() to align with standard C++ mutex methods. This allows absl::Mutex to be used with std::scoped_lock and friends. The old names are still present but may be removed in a future release.
  • The RAII Mutex-locker types like absl::MutexLock, absl::ReaderMutexLock, and friends now accept references to absl::Mutex. The pointer-accepting constructors are now deprecated, and may be removed in a future release.

Breaking Changes:

  • Nullability template types, which were deprecated in the May 2025 release, have been removed.
  • absl::string_view(nullptr), which is undefined behavior according to the C++ standard, now triggers an assert failure. Note that unless you changed absl/base/options.h, absl::string_view is an alias for std::string_view, so by default you will be inheriting the behavior of your standard library instead of using the Abseil implementation.
  • Abseil's hash tables now require a hash function that has a return type with size >= sizeof(size_t).

Known Issues

  • CHECK_<OP> is failing to compile on older versions of GCC when one of the arguments is a C-style string. This is fixed by ba9a180 and will be included in a future patch release.

Baseline: 987c57f

osrg/gobgp (github.com/osrg/gobgp/v3)

v4.9.0

Compare Source

Changelog

  • 01c5c4c GoBGP 4.9.0
  • 9d50d8e server: drop stale notifications queued while a peer session was down
  • efa0900 packet/bgp: check the per-type message length in parseBody
  • d7c721d packet/bgp: reject a body that does not match the declared length
  • 5e34ff5 test: move the KEEPALIVE length test next to the other header tests
  • e37c5a2 packet/bgp: reject KEEPALIVE messages that are not 19 octets
  • b2c73cf test: drop run_all_tests.sh and document how to run scenario tests
  • 8056d41 docs: document the listen address of the gRPC API
  • 4bbeb79 security: define what we treat as a vulnerability
  • e6c6f10 table: find the policy assignments in DeletePolicy itself
  • 4171aa9 server: drop the policy assignment of a deleted peer
  • a111094 server: store the per peer policy only for a route server client
  • c0214f7 table: report a statement that the policy does not have
  • 36cca5d table: check the import direction when deleting a policy
  • 698cc61 table: fix preserve flag in DeletePolicy
  • d4eb7d3 config: remove the collector configuration
  • 8006da4 config: log reload failures at Error again
  • 3436d72 config: log the export policy assignment failure at Error
  • 5f4a6b5 config: do not abort startup when zebra is not reachable
  • 94518c5 fix(cmd/gobgpd): delay sdnotify readiness
  • 6e08373 feat(config): return initial apply errors
  • 11a4096 server: fill in the Data field of the too long message error
  • 8f72434 packet/bgp: fill in the Data field of message header errors
  • c927e31 server: type fsmStateReason's notification as *bgp.BGPNotification
  • 88ac6da server: pass the sent NOTIFICATION to fsmStateReason in handleOpen
  • c4e13d1 server: fix wrong message wired into fsmStateReason on bad-peer-AS/invalid-msg
  • 36e6efd config: test peer group deletion against config updates
  • e585c39 config: fix deleting peer group and neighbor together
  • eb2a727 packet/bgp: include the type in an unknown route distinguisher string
  • f9152c2 packet/bgp: keep the value of an unknown route distinguisher
  • 33539ee apiutil: round-trip the SR-MPLS Binding SID label through the API
  • 8b19441 tcp-ao: expose HMAC-SHA256 profiles
  • 9341943 netutils: support HMAC-SHA256 for TCP-AO
  • cb123e9 spell-check: keep dictionary.txt sorted
  • d7ae493 spell-check: fix the "mututally" typo
  • 3b05300 config: load TCP-AO keychains from config
  • c32c92f config/oc: add TCP-AO keychain model
  • dae5a6c config/oc: reject out-of-range integers in the config file
  • 1b84a40 packet/bgp: add a test for concurrent Serialize
  • e7f8d7e packet/bgp: do not cache the message length in the BGP header
  • b010677 packet/bgp: do not store the serialized length in OPEN
  • caccf7b packet/bgp: do not store the serialized value in the capability
  • 3b6ff68 packet/bgp: make capability Len independent of Serialize
  • a40450d server: hold fsm.lock when reading fsm.recvOpen
  • 8c84624 cmd/gobgp: document the I-PMSI route target as required
  • aac7dea cmd/gobgp: validate I-PMSI route target before use
  • 42abd24 packet/bgp: serialize the full SID in the SRv6 Binding SID sub-TLV
  • c0d5851 packet/bgp: set the bottom-of-stack bit in the VPLS Label Base
  • 708c180 packet/bgp: compare the decoded NLRI in the VPLS round-trip test
  • 45c9244 packet/bgp: cover the VPLS BGP-AD NLRI at the MP_REACH level
  • 62f3d94 packet/bgp: re-serialize the VPLS NLRI in the fuzz target
  • 96105cb packet/bgp: drop the stale RFC 6074 comment in the VPLS NLRI decoder
  • 7b1d80a reject VPLS NLRI with a length other than 17
  • 02bcba0 ci: make the YANG check fail when pyang fails
  • f626c40 tools/pyang_plugins: declare the route-family typedef
  • 84868f8 tools/pyang_plugins: drop the ineffective ip-prefix deviation
  • 9c22b63 ci: add job for yang files diff
  • 97ff24e config: fix incorrect yang generation
  • 69faffb server: compare TCP-AO keychain messages with proto.Equal
  • f306bba server: run the TCP-AO validation cases inside their subtests
  • e68a92f server: spell the TCP-AO keychain store field as one word
  • 2328707 api, server: drop the keychain from the TCP-AO add response
  • 407deba server: treat the TCP-AO keychain list name as a filter
  • 0e9a005 server: reject out-of-range TCP-AO key IDs on keychain update
  • aba1929 server: implement TCP-AO keychain management
  • a7251b9 api: add TCP-AO keychain configuration API
  • 8e65579 zebra: drop dead pos increments in zapi tests
  • 55eb7a8 api, cli: surface the flowspec redirect-to-IP action
  • 58940aa packet/bgp: add flowspec redirect-to-IP extended communities
  • ad3e7c2 packet/bgp: bound MUP Type 2 endpoint address length to address family
  • 5bf33cf zebra: reject a nexthop label count above the maximum
  • b7d523b fix(server): avoid mutating Adj-RIB-In when listing accepted paths and refactor
  • b6a519b server: reject an unknown peer group in the dynamic neighbor API

v4.8.0

Compare Source

Changelog

  • 1049522 GoBGP 4.8.0
  • 4e349f6 server: withdraw filtered secondary routes on soft reset out
  • 93dd9a6 packet/bgp: always include the mask length in RTC NLRI strings
  • 1bccb27 packet/bgp: reject Route Target Membership NLRI longer than 96 bits
  • 21ccfb9 packet/bgp: make Route Target Membership NLRI codec RFC 4684-correct for all prefix lengths
  • 6934f7d table: add rtc-prefix match for prefix-set policy conditions
  • bd337ca table: don't infer a fixed ASN from an alternation community pattern
  • 440a3b1 packet/bgp: bound the update attribute scan to its declared length
  • 5a369ed bfd: discard received packets with an unbound discriminator
  • 1d16f3d table: send IPv6 extended communities in their own attribute
  • 9c13d68 packet/bgp: keep extended community decoders inside their community
  • a74cb86 ci: run buf generate from proto so the diff check has an effect
  • 4c9c9f6 apiutil: reject unparseable BGP-LS addresses instead of panicking
  • 3d78f01 api: give BGP-LS link identifiers explicit presence
  • 016ac48 apiutil: reject absent BGP-LS sub-messages instead of panicking
  • 6f6e630 netutils: fix SA5011 nil-deref warning in bindInterface test
  • b6c58c8 packet/bgp: validate declared lengths in Prefix-SID SRv6 TLVs
  • ca4873f packet/bgp: handle absent Multi-Topology ID in SRv6 SID NLRI
  • 173621f packet/bgp: reject zero-length next hop for families that require one
  • 86bc653 test(rtc): add scenario test for rtc policy filtering and change base check from adj-in to global rib
  • ea7e972 chore(deps): bump google.golang.org/grpc from 1.79.3 to 1.82.1
  • 0378ad6 packet/rtr: bound RTRIPPrefix prefix and max length to address family
  • e1bf959 packet/bgp: clamp SR Policy NLRI endpoint to declared length
  • 31e136b server: return an error from watch instead of a nil watcher
  • 88b4238 fix(server): prevent watcher leaks during shutdown
  • 08ee396 netutils: add TCP-AO socket helpers
  • 4e17218 server: resolve unnumbered NeighborInterface before validating neighbor address
  • a7028f3 packet/bmp: validate declared length in TLV16 value decoders
  • 3e854ce pkg/server: fix Loc-RIB BMP Peer Up to match RFC 9069
  • 28ba85f bfd: discard received packets with a zero Detect Mult
  • c1612bf bfd: derive detection time from remote timers
  • d0f1080 server/bmp: report Adj-RIB-In withdrawals to clear ribout on peer down
  • 69da7bf packet/bgp: reject out-of-range prefix length in EVPNIPPrefixRoute
  • 3272a76 docs: update srv6_mup.md for draft-ietf-bess-mup-safi-01
  • 0845830 cmd/gobgp: support MUP ST route TLVs and extended community formats
  • 7d2ace1 api: add MUP ST route TLVs and MUP extended community formats
  • 71d2cc3 packet/bgp: add interwork segment and address-format sub-types to MUP extended community
  • c2359e4 packet/bgp: add optional TLVs to MUP Type 1/2 ST routes
  • dc951ac server: rely on lazy path attributes hash
  • a3f0566 table: make lazy path attributes hash consistent with eager sites
  • 635293c table: fix Path.Equal ignoring nexthop and NLRI payload
  • a06cf9d packet/bgp: clamp flowspec components to declared NLRI length
  • a310174 zebra: reject ZAPI header with Length below header size
  • 0d1ad1b packet/mrt: fix attribute-length truncation in parseRibEntry
  • eba905d add a test that demos that the error messages related to misconfig remain the same
  • 7df6ba2 Support Config Via io.Reader
  • 5f30deb packet/bgp: fix SRv6InformationSubTLV sub-sub-TLV decode over-read
  • 0b5e3dc chore(deps): bump golang.org/x/net from 0.48.0 to 0.55.0
  • 8885f0b Propagate BindToDevice to GetBgp
  • ab3b92f bgp: fix build break, gofmt and stale tests in BGP-LS String() methods
  • 5b918d2 style: fix gofmt formatting
  • b993c6d bgp: fix BGP-LS Link/Prefix NLRI key collision for IS-IS L1/L2

v4.7.0

Compare Source

Changelog

  • 8b5edc2 GoBGP 4.7.0
  • 441fcb6 ignore Claude files
  • 4a9c2a5 Use Interface/Device Bindings for BFD
  • 1ad1e03 tools: add FlowSpec auto-mitigation example
  • 8c4802d ci: replace fabric with shell script for building container image
  • d6dee83 scenario_test: migrate test runner from nose to pytest
  • 09276f7 server: fix Downtime updated on reconnection intermediate transitions
  • 3c0164f scenario_test: fix route server policy to use export direction
  • 40817e6 gobgp: support last-as keyword in as-prepend action
  • 1cf53c9 scenario_test: fix route server policy direction and test infrastructure
  • e474954 ci: enable IPv6 for route server scenario tests
  • 3acd19f table: fix REPLACE with empty community list not propagated to API
  • 737a626 table: fix case-sensitive community action type in toStatementApi
  • 2132288 fix: register bfd for dynamic neighbours
  • e5286bb scenario_test: update route_server_malformed_test to match RFC 7606 behavior
  • 8ab4f8a fix: pass zone for LLA BFD peer
  • f6cc73a server: fix GR LocalRestarting not cleared when transitioning peer appears as OPENCONFIRM
  • 4092db3 config: propagate bind-interface from peer-group transport config
  • 4a319a6 packet/bgp: reject empty AS_PATH in confederation eBGP validation
  • 7325b9d Add missing scenario tests for TCP MD5
  • 5581749 config: Plumb global bind-to-device from file config
  • 76ece66 Support VRF for TCP MD5
  • 21830f7 config: remove trailing whitespace from gobgp.yang
  • fffa3d5 bgp-ls: accept prefix-length 0 in LsTLVIPReachability (default route)
  • 944dece zebra: set ifindex for IPv6 link-local next-hops
  • 7204bf9 packet/bgp: fix TunnelEncapSubTLVSRCandidatePathName decode over-read
  • 9f62e5b packet/bgp: include Link Local/Remote Identifier in LsLinkDescriptor.String when both shapes are present
  • 8866bd7 table: fix ext-community-set match-set-options ALL and INVERT
  • 94e64d6 fix global rib peer addpath
  • c57da62 fix multipath when use bmp or monitor
  • 7743c50 ci: scope GITHUB_TOKEN to minimum required permissions
  • e25cefa Require @​fujita review for workflow changes
  • 0cc5ed4 packet/bgp, apiutil: gofmt fixups in the RFC 9351 stack
  • 86958d5 apiutil: end-to-end wire test for RFC 9351 FAD + multi-SID Prefix-SID + FAPM
  • cea5414 packet/bgp: render FAD sub-TLVs in LsTLVFlexAlgoDef.String for CLI output
  • c29c820 api, apiutil: surface RFC 9351 Flex-Algorithm Definition + multi-SID Prefix-SID
  • e112129 packet/bgp: add RFC 9351 Flex-Algorithm Definition + multi-SID Prefix-SID
  • b3989e1 server, table: advertise the cap, negotiate it, and gate the per-session length
  • 877913e api, apiutil: surface the BGP Extended Message capability
  • e1268db packet/bgp: add the BGP Extended Message capability (RFC 8654)
  • 41b5bb6 table: cache NLRI string in originInfo to avoid repeated allocations
  • 6f2cf37 server: use sync.Map.Clear() in resetAdvertisedRoutes
  • 6331854 server: avoid global propagation locks in resetAdvertisedRoutes

v4.6.0

Compare Source

Changelog

  • 5151100 GoBGP 4.6.0
  • 84a98f8 server: withdraw policy-filtered routes on soft reset out
  • 41e47a8 fsm: Do not emit warnings upon receiving notification
  • 748e233 server: don't treat unestablished GR peers as having sent EOR
  • c4fd8f2 pkt/server: return error instead of panic on invalid SourceId in AddPathStream
  • d43ff16 feat: add as-path-options params for peer-group api and config parser
  • 1affa9a docs(bfd): add docs for using and configuring bfd session state detection
  • e0d6b99 fix(table): preserve last action for the same path in coalesced updates
  • f9448f0 feat: add local caps and peer-group to watchEventPeer
  • 77a5cb0 fix(bfd): fix peer shutdown, remote down, and default port
  • 4ebc2d3 fix(bfd): fix goroutine leak, safe public API, remove read event loop
  • 0aef2d8 feat(bfd): add BFD server and peer state machine
  • 89ec8ad fix(cmd): avoid nil pointer panic in CLI when NLRI cannot be decoded
  • f0a540b feat(table): extract communityAnyIndex and add fast match for ext-comms
  • df0fb4d table: Do not emit warnings upon no-op withdrawals
  • 78d1c56 fsm: Do not emit warnings upon sending notification
  • c246294 refactor(table): drive UpdatePathAttrs from PeerInfo only.
  • accb63b feat(table): extend PeerInfo and add peer-group helpers for policy paths Expand PeerInfo with PeerType, route-server flags, remove-private-as, peer group name, and related neighbor/group fields so table logic can treat peer-group shared-policy paths consistently with per-peer paths.
  • a89819e refactor(config): move IsConfederation methods from Neighbor to Global
  • 3be7559 perf(table): bitmap-based fast path for standard BGP CommunitySet
  • ace3800 fix(server): compare ECMP paths against best path, not predecessor
  • ed9ec4f fix(cmd/gobgp): allow multiple RTs in mup route commands
  • 941f597 packet/bgp: propagate errors and enforce length bounds in BGP-LS NLRI decoders
  • 5d52dd1 packet/bgp: prevent nil pointer panic in TunnelEncapSubTLVSRBSID String and MarshalJSON
  • 7b3e555 packet/bgp: reject malformed MPLS label stacks missing bottom-of-stack bit
  • b6bfd5d apiutil: add tests for UnmarshalSRSegments nil Flags and round-trip
  • b22177e fix(apiutil): nil-safe Flags access in UnmarshalSRSegments
  • f02ca39 packet/bgp: enforce CapLen boundary in BGP OPEN capability decoders
  • 2ee365d fix: preserve unknown IPv6 Extended Communities in round-trip encoding
  • dd70de7 fix: evpn type2 handling without ip
  • 3072fe9 fix: nil pointer dereference for local paths in WatchPostUpdate

v4.5.0

Compare Source

Changelog

  • 5f19106 GoBGP 4.5.0
  • 264380b fix bgp-ls mt-id rib collision
  • 7899bb9 docs: recommend GOAMD64=v3 for maximum performance on AMD64
  • 8448d2c correct sub-TLV length validation in BGP-LS decoders
  • 010d6a5 feat(bfd): align BFD API
  • 90adc4a feat(bfd): align BFD schema with OpenConfig conventions
  • 4be569a feat: propagateBucket
  • a50fb45 feat: zebra client nexthopCache need to be accessed under lock
  • d60caf4 stopNeighbor under write lock
  • 57c66ea add FSMHandler race tests
  • d1cc36a s.shared.mu.RWLock
  • d6deb01 feat(bfd): parse and encode Diagnostic field per RFC 5880 §4.1
  • 4d989d8 feat: consistent routing update
  • 35aa05a fix(rtc): fix VPN path indexing — track best path (no-add-path) or all path-IDs (add-path)
  • ae1a568 feat(bfd): add RFC 5880 BFD packet codec
  • 8de689f chore(spell): add reuseaddr to spell-check dictionary SO_REUSEADDR is a standard POSIX socket option name; scspell3k doesn't recognize the combined token 'reuseaddr'.)
  • 4d098c9 feat(netutils): add SetUDPTTLSockopt and SetReuseAddrSockopt helpers
  • d12f363 watcher: serialize new watcher registration
  • 9aec25f bmp: fix reconnect on write error
  • 640b3a6 table: eliminate string round-trips in Select for IPv4/IPv6 UC
  • 00c7a4b table: fix shorter-prefix lookup returning only the first match for IPv4/IPv6 UC
  • be2b9e9 apiutil: fix wrong lookup option when converting from proto enum
  • d2d2be3 table: skip paths with unconfigured family in AdjRib.Update
  • 35adaa5 zebra: use netip.Addr as nexthopStateCache key
  • 153a25e test: use assert_several_times in zapi_v3 test
  • 83c341d test: replace OSPF with static routes in zebra-nht test
  • e26c0cc table: add unit test for new path with invalid nexthop
  • b21a8a7 test: expand unit tests for nexthopStateCache
  • 62e965a feat: (table/server) add VPN path RT index for O(1) RTC candidate lookup
  • 631de4c fix: rpki server listing panics
  • 97ca4e7 test: increase NHT test timeouts for CI stability
  • f20b97a server: fix nil pointer dereference in prePolicyFilterpath
  • b4e240e table: treat nexthop-invalid best path as no best in GetChanges
  • 075fb4c feat: rework RTC handling with RouteTargetMembershipHandler
  • c86f89e Coalesce outgoing BGP UPDATE messages
  • 11d0013 fix: ipv6 link local address with zone
  • 0d2f89d refactor: replace rtc handling logic to separate place. Key changes: 1. Move rtc registering logic to separate file 2. A little name and comments refactoring 3. Unit tests for rtc registering logic
  • 7cdba63 server: fix goroutine leak when WatchEvent outlives Serve
  • 9695ed2 Replace rtCounter (map[uint64]int) with adjRTSet (map[uint64]map[adjRTKey]struct{})
  • 55e5242 ci: replace bufbuild/buf-setup-action with go install
  • f4143fe ci: update GitHub Actions to Node 24 compatible versions
  • 0534445 fix bmp config map issue
  • a81d63d gobgpd: Fix printing of help message
  • 4643cba Add security policy for vulnerability reporting
  • 2df9ff3 atomic peerinfo or lock prefixLimitWarned, llgrEndChs
  • 9b36d84 server: Use State instead of Config to determine GR-enabled peers in StopBgp

v4.4.0

Compare Source

Changelog

  • 12b4eba GoBGP 4.4.0
  • 7e767a8 packet/bgp: use buffer length for sr-policy segment list parsing loop condition
  • f9f7b55 packet/bgp: fix infinite loop when decoding srv6 unknown sub-TLV types
  • f842cdf packet/bgp: prevent uint16 underflow in BGP-LS sub-TLV length tracking
  • 76d9110 packet/mrt: fix uint16 underflow in parseRibEntry path attribute loop
  • bc77597 packet/bmp: validate ParseBody input length before reading fields
  • 51ad1ad packet/bgp: Fix AIGP PathAttribute parser to return errors
  • 215aee0 fix: prevent nil dereference on BGP UPDATE validation and fix variable shadowing
  • 2814e72 fix: handle keepalive write error in openconfirm state
  • 60f548e netip: use github.com/gaissmai/bart Trie
  • 52fa007 build(deps): bump google.golang.org/grpc from 1.73.0 to 1.79.3
  • ad39ab1 test: fix race in TestWatchEvent
  • af16fb5 remove Locked suffix on internal API
  • af29736 cleanup Destinations RLock, iterate on per shard lock
  • 89b5acd adj.walkActive
  • 835fb96 table manager cache maxPathCounted
  • b48d135 table destination SelectDestinationLocked
  • 44a9abc table manage don't expose internal maps
  • 0ababab table/path: fix race on attrsHash
  • 91337e9 tests: add race tests for table manager
  • b55a5db EVPNMacNLRIs thread safe
  • 5a62b66 table manager lock
  • 49e5a2a table dest shard locks
  • [4819eb3](https://redirect

❗ Important

✂ PR body was truncated to here.


Configuration

📅 Schedule: (UTC)

  • Branch creation
    • Monday through Friday (* * * * 1-5)
  • Automerge
    • At any time (no schedule defined)

🚦 Automerge: Disabled by config. Please merge this manually once you are satisfied.

♻ Rebasing: Whenever PR becomes conflicted, or you tick the rebase/retry checkbox.

👻 Immortal: This PR will be recreated if closed unmerged. Get config help if that's undesired.


  • If you want to rebase/retry this PR, check this box

This PR was generated by Mend Renovate. View the repository job log.

@renovate-bot
renovate-bot requested a review from a team as a code owner September 15, 2026 16:16
@renovate-bot
renovate-bot force-pushed the renovate/major-deps branch 3 times, most recently from a29e68f to f42b907 Compare September 22, 2026 10:45
@renovate-bot
renovate-bot force-pushed the renovate/major-deps branch 2 times, most recently from 0c7786d to d7774d8 Compare September 24, 2026 23:00
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Labels

None yet

Projects

None yet

Development

Successfully merging this pull request may close these issues.

1 participant